0

I am assisting a friend by admining a website for his podcast (http://www.castlereport.us). I've had a little bit of experience with WordPress, but have no coding and customization skills. Only my friend and I have user accounts. His wife uses his account to post the new podcast episodes for him and I only log in to do occasional maintenance. 

I have the discussion settings set to allow people to comment without moderation and to not require users to be registered or logged in to comment. However, the system appears to recognize my email address and my friend's as being associated with a user account and it holds our comments for moderation until I log in and approve them. All other comments are automatically posted as should be. It would be really nice if my friend's replies to comments were also posted automatically.

Below is a screen shot of my discussion settings. I've sat and stared at that page over and over again trying to figure out how to let my friend's comments be posted without moderation and without having to be logged in, but it seems to be escaping me. I have the same situation on another website, so it's not just a fluke.

enter image description here

0

Those setting should allow anyone to comment (but they have to enter their name/email). (Side note: I usually uncheck the first two option.).

Perhaps the individual posts have disabled comments? Look down below the post editing area for that checkbox (you might have to enable that area via the 'screen' dropdown on the top of the page).

If comments are disabled on an individual post, you shouldn't see the 'comment' area below the post.

It is slightly possible that your theme doesn't allow comments. Change to one of the default themes to see if the comments area (on a newer post) reappear.

Note that your settings do not allow comments past 60 days, so make sure you are testing on a newer post.

  • Well, it turns out it wasn't the theme, but your suggestion got me to thinking and I remembered that plugins can sometimes cause issues. By processes of elimination, I narrowed it down to Wordfence. It might be a setting within Wordfence, or just a conflict. Wordfence has too many settings and I'm too tired to methodically go through them all right now, so that will have to wait until tomorrow. Thanks for the prompting! – Bob Peck Jul 11 '17 at 11:07
  • Okay, I couldn't help myself, even in my sleep impaired state I just had to go look at the Wordfence settings. Toward the bottom of the "Options" section I found a check box for "Hold anonymous comments using member emails for moderation." I unchecked that and it solved my issue. My head was stuck on the discussion settings thinking the answer had to be there. – Bob Peck Jul 11 '17 at 11:26
  • Glad you got it working. Plugins are often suspects in weird things happening to a site. (It's 'customary' here to use the checkbox if the answer is correct or helpful; it also alerts others later that the answer might be helpful to their similar questions.) – Rick Hellewell Jul 11 '17 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.