0

The permalink structure has changed with old entries as well as any new entry (post, object, etc) from THEN to NOW

THEN:

constructstudies.com/(page slug or object label)

NOW:

constructstudies.com/disability-application/disability-benefits-application/disability-application/(page slug or object label)

The redundant parent labels cannot be altered under permalinks settings, nor with the 4 custom permalink plugins I have tried. The structure is embedded deeper than these settings allow.

It should be noted that in attempts to better my link structure, I have created and subsequently deleted 3 versions of similar parent pages with no more than one present at any given time. Two were labeled disability application and the other disability benefits application.

Why have these old titles carried over into the permanent URL structure and how can I fix this? Ive deleted revisions with WP optimize, gone into myphpadmin and deleted old like entries from the wp_febe_posts table, cleared all cache, tried to delete and recreate pages, alter the .htaccess file to reflect a single-label permalink structure, and searched endlessly on forums and google.

I'm uncertain whether deleting the old parent page entries and revisions in wp_febe_posts table via myphpadmin is the same as doing so in WP_pages via FTP, as I have searched endlessly for this to no avail so I cannot confirm.

My strongest suspicion is something awry in my .htaccess file, as I have made several changes to it over the past couple of weeks and have limited knowledge of the changes beyond what was explained in the articles which accompanied respective modules i copy pasted.

Below is the contents of .htaccess files. This file in the root directory is identical to the entry within my public_html-->constructstudies directory

-Please help me remedy this befuddlement and get me back to work. Thank you.-

EDIT:I returned to my site to find a fourth /disability-application appended to the permalink structure. As suggested on worpress.org forums, i have deleted my htaccess file as it was indicated there were redundancies within it. Also, I read that my results could be produced by a command but i have no recollection of this nor is it found in any of the basic editor phps within dashboard. just thought it may be worth noting.

.htaccess: (any general suggestions welcomed as well)

 <IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule ^sitemap(-+([a-zA-Z0-9_-]+))?\.xml(\.gz)?$ /public_html/constructstudies/sitemap$1.xml$2 [L]
</IfModule>
# BEGIN W3TC CDN
<FilesMatch "\.(asf|asx|wax|wmv|wmx|avi|bmp|class|divx|doc|docx|eot|exe|gif|gz|gzip|ico|jpg|jpeg|jpe|webp|json|mdb|mid|midi|mov|qt|mp3|m4a|mp4|m4v|mpeg|mpg|mpe|mpp|otf|_otf|odb|odc|odf|odg|odp|ods|odt|ogg|pdf|png|pot|pps|ppt|pptx|ra|ram|svg|svgz|swf|tar|tif|tiff|ttf|ttc|_ttf|wav|wma|wri|woff|woff2|xla|xls|xlsx|xlt|xlw|zip|ASF|ASX|WAX|WMV|WMX|AVI|BMP|CLASS|DIVX|DOC|DOCX|EOT|EXE|GIF|GZ|GZIP|ICO|JPG|JPEG|JPE|WEBP|JSON|MDB|MID|MIDI|MOV|QT|MP3|M4A|MP4|M4V|MPEG|MPG|MPE|MPP|OTF|_OTF|ODB|ODC|ODF|ODG|ODP|ODS|ODT|OGG|PDF|PNG|POT|PPS|PPT|PPTX|RA|RAM|SVG|SVGZ|SWF|TAR|TIF|TIFF|TTF|TTC|_TTF|WAV|WMA|WRI|WOFF|WOFF2|XLA|XLS|XLSX|XLT|XLW|ZIP)$">
   <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteCond %{HTTPS} !=on
      RewriteRule .* - [E=CANONICAL:http://www.constructstudies.com%{REQUEST_URI},NE]
      RewriteCond %{HTTPS} =on
      RewriteRule .* - [E=CANONICAL:https://www.constructstudies.com%{REQUEST_URI},NE]
   </IfModule>
   <IfModule mod_headers.c>
      Header set Link "<%{CANONICAL}e>; rel=\"canonical\""
   </IfModule>
</FilesMatch>
<FilesMatch "\.(ttf|ttc|otf|eot|woff|woff2|font.css)$">
<IfModule mod_headers.c>
    Header set Access-Control-Allow-Origin "*"
</IfModule>
</FilesMatch>
# END W3TC CDN
# BEGIN WordPress
AddHandler application/x-httpd-php70s .php
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /disability-application
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /disability-application/index.php [L]
</IfModule>

# END WordPress
AddHandler application/x-httpd-php70s .php
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

# Wordfence WAF
<Files ".user.ini">
<IfModule mod_authz_core.c>
    Require all denied
</IfModule>
<IfModule !mod_authz_core.c>
    Order deny,allow
    Deny from all
</IfModule>
</Files>

# END Wordfence WAF
0
0

go under setting>permalinks, you should see the options there. This also depends on if you are using a custom post type in which case you have to edit a line of code to correct the permalinks

1
  • no custom posting-old parent labels are stacking on top of one another in the un-customizable URL structure... – Preston Bennett Jul 9 '17 at 19:52
0

The most common solution is going to Settings->Permalinks-> making sure the URL format is correct, and simply hitting Save. A step further is to first delete your .htaccess file after purging all cache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.