1

I've noticed that when I type:

http://domain.tld/c (which does not exist)

somehow, for some reason I'm directed to

http://domain.tld/contact (which exists)

I found that this is default behavior at least in recent versions of Wordpress.

How to control-disable this?

1

This question is a duplicate of Disable ONLY URL auto complete, not the whole canonical URL system

Try this filter

function remove_redirect_guess_404_permalink( $redirect_url ) {
if ( is_404() )
    return false;
return $redirect_url;
}

add_filter( 'redirect_canonical', 'remove_redirect_guess_404_permalink' );

Or this plugin: https://wordpress.org/plugins/disable-url-autocorrect-guessing/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.