0

I am having multiple problems with installing new / updating plugins in Wordpress, and am hoping they're all linked to 1 problem that I can easily fix. I've been googling for hours and just can't crack it. I will add that it used to work, so something seems to have changed (all I can think of is permissions? my /plugins folder is set to 755').

  • When I try to install a plugin it comes back almost immediately saying:

'Unpacking the package… Could not create directory.'

  • When I try to update plugins it says they've been updated, but they have not (a simple refresh shows that they haven't).

  • When I try to install new plugins, I can't search for new plugins. I can view 'featured' / 'recommended' etc, but everytime I search I have the follow error message showing in my plugin page:

'SSL: certificate subject name 'demo.ait-themes.club' does not match target host name 'system.ait-themes.club'

Really hoping someone may have some ideas!

  • Update plugins. Check if wp-content has permissions set to 755. If not, then WP cannot create upgrade folder in it. – Frank P. Walentynowicz Jun 28 '17 at 8:38
  • I agree with Frank, however an alternative might be to use direct FTP connection within WordPress. Put this in your wp-config.php: define('FS_METHOD', 'direct'); and see if it works. – user3135691 Jun 28 '17 at 8:56
  • Please read my description - I cannot update plugins and my permissions on that folder are already set to 755. I also already have 'define('FS_METHOD', 'direct');' in my wp-config.php file. If I don't, it wants my ftp password everytime to connect (but doesn't). – IVCatalina Jun 28 '17 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.