1

I have migrated my site from jojofun.co.uk to jojofun.ca. However, the images are not displaying at the new URL.

If you visit the new URL at jojofun.ca, you will see missing images - the only ones loading are those still being loaded from the old domain (in the header and footer).

I updated the database on the new site so the old URL is replaced with the new URL using this search replace script https://github.com/interconnectit/Search-Replace-DB

On the homepage, you can see by copying the image location of a broken image and loading it in a new tab that the image loads. So the images do exist on the server, however they are not loading on the page nor in the media library.

Any ideas?

Thanks Andy

  • The images are not broken. They are just blocked by your server. Your uploads folder might not have the proper permissions, or you might have rules in your .htaccess file that is blocking them. By the way your uploads folder has directory listing enabled. You should disable this. – Jack Johansson Jun 21 '17 at 12:43
  • 1
    Hi Jack. Thank you for this. There was code in the .htaccess placed there by the security plugin I'm using - I've updated that code with the new URL and now the images load. I've also added this line to my .htaccess file to disable directory listing: "Options -Indexes". Thanks again. – Andy Wood Jun 21 '17 at 13:10
0

Look at your folder "uploads" permissions, it should be 755. More information here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.