0

I've these two CPT: Publications and Books.

The custom rewrite slug for Publicationsare just /publications/
I want the Books CPTs rewrite slug to be /publications/books/

But I do that and I get an 404 error when navigating to site.com/publications/books/wordpress-is-great

Most certainly be cause it is the publications rewrite rules which "step" in and not books but I can't seem to figure out how to make this work and "combining" parts of the rewrite slug for Publications.

0

The URL reads as if books is a sub taxonomy of publications.

Try using 'publications-books'

Don't forget to re-save the permalinks in the settings -> permalinks options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.