0

I have my URLs all right in the database (at least, "Better Search & Replace" doesn´t find the faulty ones, neither does phpMyAdmin), but in the frontend they are messed up.

Basically http:// is missing the : so images won´t load correctly, links are wrong etc. pp.

Home and Website URL are fine in the backend and some images and links are working. I already deleted and rebuilt the .htaccess, so it´s not about that either, I think.

What might cause this behaviour? Strangely configured server of the client?

Update 1: I tried disabling all plugins and switching to a standard theme. This didn´t change anything.

6
  • 1
    If it's on NGinx, there may also be a server config file in addition to .htaccess. Outside of that, I would switch to a default theme & deactivate all plugins, then check - using an Incognito window or a http header checker so your browser cache doesn't come into play - and see if the problem is still there.
    – WebElaine
    Commented Jun 19, 2017 at 17:35
  • 1
    You might also try viewing the "Settings > Permalinks" page (just a pageload, no need to make changes or save) to refresh permalinks.
    – WebElaine
    Commented Jun 19, 2017 at 17:36
  • 1
    Media urls are generated dynamically. Check out the urls in the Media Library. If the image urls are good in there, then you probably have a plugin that is re-generating the urls incorrectly.
    – user42826
    Commented Jun 19, 2017 at 20:19
  • Thanks, I will have a further look into that and come back on this again...
    – flomei
    Commented Jun 19, 2017 at 22:17
  • Just looking into it. The URLs are all fine in the media library, so I will give the plugins a try now.
    – flomei
    Commented Jun 20, 2017 at 6:25

1 Answer 1

0

Ok, this was pretty strange. While only http// showed up in the URLs the database fields for the corrupted URLs were http://http// which obviously resulted in the error. I did another search & replace for those "double http" and that fixed it in the end. Still no idea why this only happened to some URLs but I´m happy I figured it out.

So having a second look, two days later, sometimes is a valid solution. :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.