0

We use the WP RSS Aggregator plugin to gather feeds from various sources. Our site previously ran on HTTP. After switching to HTTPS, the plugin has stopped working. If I manually try to fetch the feeds, nothing happens. The WP RSS error log is empty. Does anyone have any ideas as to why this might happen? It seems like a minor change that wouldn't effect the plugin from curl'ing down feeds.

UPDATE:

It's definitely an issue with our reverse proxy setup, but I'm not sure how to address it yet.

The problem is with WP-cron and our reverse proxy setup. The SSL is terminated at the nginx layer. Our backend Apache servers are only talking HTTP. So I get the following error from WP-Cron:

There was a problem spawning a call to the WP-Cron system on your site. This means WP-Cron events on your site may not work. The problem was: 
cURL error 7: Failed to connect to www.example.org port 443: Connection refused
  • I'm guessing you also posted to their support forum at wordpress.org/support/topic/…. Have you tried enabling WP_DEBUG to see if there are any errors? – Morgan Estes Jun 14 '17 at 4:42
  • Yes, posted there as well. It's a production cluster, so I'm hesitant to enable WP_DEBUG just yet. I was hoping there might be an explanation I was overlooking. – blindsnowmobile Jun 14 '17 at 6:04
  • Would appreciate an explanation on the downvote. – blindsnowmobile Jun 14 '17 at 6:05
  • If you're behind a proxy, it's possible that curl is having a hard time handling SSL verification. That usually affects inbound, but I had it happen on outbound requests recently. – Morgan Estes Jun 14 '17 at 6:09
  • Yes, we're behind an nginx proxy, with SSL terminated at the proxy. The backend servers all talk over standard port 80 still. We switched the WP config file over to https, so maybe that's causing an issue when the importer runs. Thanks - I'll investigate that further. – blindsnowmobile Jun 14 '17 at 22:03
1

This sounds like your local DNS settings resolve your domain name to the server instead of going properly to the proxy. hmm, reading the question again, if the proxy is on the same machine, you might have some firewall misconfiguration.

Best long term solution is just not to rely on the wordpress cron and replace its use with the OS cron https://developer.wordpress.org/plugins/cron/hooking-into-the-system-task-scheduler/ .

  • It was a firewall issue. The resolution was to switch to OS cron as detailed in your link. I also needed to clear out many of the older events before it started working proplerly. I did this using the wp cli, removing all wprss_* events like this: "wp cron event delete wprss_fetch_single_feed_hook". Thanks! – blindsnowmobile Jun 24 '17 at 1:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.