0

I posted this on stackoverflow and they said i can try here -

I have wordpress installed on my website. On that site, under a subfolder i have oscommerce system installed as online commerce store.

I activated permalinks on my wordpress, But now everytime i try to reach the store administration i get page not found in the wordpress.

If i'll disable the permalink i can gain access again, can you please help?

Thanks as always, Danny

  • Do you have htaccess file in your root folder of wordpress? – Niraj Chauhan Aug 26 '11 at 14:54
  • also, are rewrites activated on your site? – Manny Fleurmond Aug 26 '11 at 16:23
1

When you enable permalinks in Wordpress, it creates an htaccess file in whatever directory it's located in. Since Wordpress is installed in the root directory, there will be an .htaccess file there that enabled permalinks.

It is possible that the rewrite rules that WordPress is producing are interfering with your install of ecommerce.

If ecommerce doesn't use an .htaccess file in the directory it's installed to, you can create a blank one in the ecommerce folder.

You may need to add this to your .htaccess file

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /ecommerce_folder/
</IfModule>

This will prevent whatever rewrite rules wordpress is using from affecting that folder.

You may also want to see this post: How to avoid wordpress permalink rules to inherit in a sub-folder

0

Are you running wp on an IIS (win) server? Check this -> Codex - Using Permalinks w/o mod_rewrite

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.