0

/ru - default directory, how can I remove it

this link: https://cambridge.ua/ru/teachers/ should be: https://cambridge.ua/teachers/

<ul class="language-chooser language-chooser-text 
qtranxs_language_chooser" id="qtranslate-chooser">
    <li class="lang-ru active"><a href="https://cambridge.ua/ru/teachers/" 
hreflang="ru" title="RU (ru)" class="qtranxs_text qtranxs_text_ru">
<span>RU</span></a></li>
    <li class="lang-en"><a href="https://cambridge.ua/en/teachers/" 
hreflang="en" title="EN (en)" class="qtranxs_text qtranxs_text_en">
<span>EN</span></a></li>
    <li class="lang-uk"><a href="https://cambridge.ua/uk/teachers/" 
hreflang="uk" title="UK (uk)" class="qtranxs_text qtranxs_text_uk">
<span>UK</span></a></li>
</ul>
<div class="qtranxs_widget_end"></div> 
0

Go to general plugin's options - /wp-admin/options-general.php?page=qtranslate-x#general and in section "URL Modification Mode" choose "Pre-Path Mode" and then also check "Hide URL language information for default language" - like this:

enter image description here

  • this modification only for url, if I go to inspect element its steel got /ru – ilushoni Jun 9 '17 at 7:04
  • Without the magic /ru in the address https://cambridge.ua/ru/teachers/ you won't be able to change the language version back to ru. – Picard Jun 9 '17 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.