0

I have a problem with my FTP uploads. I'm trying to upload my plugins via FTP like always, but this time, plugins are not on my site.

I have check the permissions (755-644):

enter image description here

enter image description here

If I install plugins via wordpress admin panel, they appear without problems.

I have installed more than 100 wordpress, but it's first time it happens to me.

Thank you so much.

PS: I also tryed to install one by one, but the result is the same. I have checked and the files are on the server.

  • Hugo, check the ownership of the plugins that you're uploading manually. In some cases the FTP user and the Apache user are different. – Steve Jun 4 '17 at 13:31
  • Hello @Stephen, thank you so much. How can I do that? check the ownership of the plugins. I'm trying to observe the differences between ftp and directly installed files and I do not see them. Both are on the server with same permissions . – Hugo L.M Jun 4 '17 at 13:42
  • That all depends upon your access to the server. If you have SSH access it's fairly straight forward, if you have web based file manager (i.e. cPanel) then use the file manager. – Steve Jun 4 '17 at 14:01
  • Thank you, but the ownership is the same; checked via file manager. – Hugo L.M Jun 4 '17 at 15:02
1

Solution found.

In this case, the problem was the path name. It included a folder with a keyword that the server should reject: "worm".

While for the template was not a problem, for the plugins folder it was.

  • I removed [SOLVED] from the title. Please consider marking your answer as accepted. – Jack Johansson Jun 5 '17 at 0:54
  • By now, I can't; 48 hours limit. It is just a note until then. – Hugo L.M Jun 5 '17 at 0:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.