0

Wordpress newbie here, I can't seem to fix this. I've looked all over for it and I want people to be able to use both www and non www, but right now only www.website.com works. I'm using a fresh instalation on the root folder, so feel free to tell me to reinstall.

  • What are you wanting to do? Have it so example.com goes to www.example.com? Have the two be the same? etc. – Cedon May 22 '17 at 19:38
  • 99% chance you have redirects in place. Most likely if you FTP in to the site, in the root folder, there is an .htaccess file that is performing this redirect. If you're using a CPanel host check for redirects there - you can often remove them directly from CPanel without editing .htaccess directly. – WebElaine May 22 '17 at 19:43
  • For both search engines and visitors it's best if you redirect to either www or non www. Here are directions for both: htaccessbasics.com/force-www-nonwww-domain – WebElaine May 22 '17 at 19:44
  • @belinus Force the URL to display either www or non www ALWAYS and make both work. – Pedro Cavalheiro May 22 '17 at 20:14
  • @WebElainei Checked cPanel, nothing.This is my .htaccess file: pastebin.com/ZmgQiPJT – Pedro Cavalheiro May 22 '17 at 20:15
0

Probably you have a redirect settings in your .htaccess file
This is a hidden file, You can use your file manager to edit this file and check for any redirect settings in this file

If your web hosting panel is CPanel, you may find that in Redirect section in CPanel too

Or may be it's a browser cache, So clear your browser cache and then try again
To check browser cache, You can use this trick: www.sitename.com/?
Use a question mark after a slash sign in the end of address

  • Nothing on CPanel, here's my htaccess file: pastebin.com/ZmgQiPJT – Pedro Cavalheiro May 22 '17 at 20:17
  • Can you provide your site link? – Farhad Sakhaei May 22 '17 at 20:20
  • (censored).com - goes to index.html (censored).com - proper one – Pedro Cavalheiro May 22 '17 at 20:20
  • I checked it, both address goes to 'censored' – Farhad Sakhaei May 22 '17 at 20:22
  • Or may be it's a browser cache, So clear your browser cache and then try again – Farhad Sakhaei May 22 '17 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.