0

I'm kinda stuck here. My home page is set to show the recent posts and in my menu I have home page link. But it's not highlighted as current - screen When I click on the home link I transfer to the empty home page and the link is highlighted. How to make the home highlighted if I'm on the page with recent posts?

Additionally, I have 2 sub-menus, I want that first link in submenu will redirect me on the home page (with recent posts), not the empty "Home".

1

Typical menu structure with 'Home' item being a Custom Link and other menu items being pages:

Typical Menu

The 'Home' menu item must not point to a real page and should look like that:

Home

The 'Home' menu item stays the same, regardless of the choice you've made in Settings -> Reading -> Front page displays.

Remove the page 'Home', you've created, then edit your menu, and remove menu item 'Home', which points to 'Home' page. Save your menu. Now, by clicking on 'Home' menu item ( custom link ), you'll get your posts displayed, and 'Home' will be highlighted.

  • Thanks. But if I type a slash, now the link is following to dashboard and the home is still not current. I'm working on a localhost. The solution that I found is if I type URL localhost/wordpress then the home become current. But when I move the website to live is this link will change as well? – Alexander May 25 '17 at 2:13
  • @Alexander did you use a right slash alone, without preceding http://? That should work in any environment. I've never had problem with single right slash. It always points to the root of your website, at least for non local environments. When you move to a live website, you can use '/' safely. – Frank P. Walentynowicz May 25 '17 at 2:57
  • Yes, I tried right slash alone and the home link goes to localhost/dashboard – Alexander May 25 '17 at 3:38
0

1- When you are in a page there is a css class called "current-menu-item" assigned to that menu. I thought you should assign your recent blog post as your static homepage and in menu section change that name with home. Hope it will works.

2- Assign a page as blog post from settings > reading and then make assign that page in your submenu. If you have any live url that would be best for me to give you correct answer. Thanks

  • If I set Static Front Page to Posts page -> Home, now I have 2 homepages, one without slug "home" and other with slug 'home' which is set as current if I click in navigation on that link :) – Alexander May 22 '17 at 5:46
  • Is your problem solved ? Do you have any live url ? – Mehedi_Sharif May 22 '17 at 23:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.