0

I’m completely new to wordpress/website design and I’m following a tutorial on youtube about creating custom themes. I’ve set up a website in localhost and I’m using permalinks to navigate to pages in the website. However, when I try to use the permalinks, it gives me a ‘403 forbidden’ notice and says that "I don't have permission to access the permalink on this server."

After investigating online it looks like my problem is that the apache and php code are not allowing the permalink to work, and I’ve found videos online about how to fix this but the videos are years old and on the apache httpd.conf file the code has changed, and also on phpmyadmin.conf, so I’m not sure how to fix it.

Thanks in advance,

Javier

0

Somethings wrong with your permission setting.

Login to your server via SSH. You can login using your terminal. I've created a blog about how to connect to your server via SSH if you're using windows.

Run the following commands:

chown www-data:www-data  -R * # Let Apache be owner
find . -type d -exec chmod 755 {} \;  # Change directory permissions rwxr-xr-x
find . -type f -exec chmod 644 {} \;  # Change file permissions rw-r--r--

Hope this helps.

-Dave

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.