0

I've recently uploaded a blog post to our site, and when logged into Wordpress, it shows up as normal on the blog homepage.

However when logged out, it doesn't show up.

What's strange is that if you are logged out and go directly to the URL there is no problem seeing the post. Similarly, it's showing up in the recent posts sidebar.

The post is set to public. Any ideas?

2
  • 1
    Do you have any caching plugins on your site?
    – Aravona
    Commented May 9, 2017 at 10:13
  • 1
    to get a quality answer, there needs to be some effort in producing a quality question. For the question as it is now might be about 20 different possible answer which means that you are asking people to guess not to answer. Please do some debuging by yourself, as right now this is just a waste of your time and everybody else's time Commented May 9, 2017 at 12:04

1 Answer 1

2

This sounds like an issue where the homepage is served out of a page cache, rather than generating live. Usually, when you are logged in, you are bypassing the cache and seeing a live generated page. If you have a caching plugin activated, try clearing the page cache and load the homepage again.

If that works, you'll want to check your settings to ensure that the homepage cache is cleared whenever a post is published.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.