1

Since a few days, Wordpress behaves strangely.

I’m using the latest version of Wordpress (4.7.4). I have something very weird going on in my Dashboard. Not sure when this started. Can’t say for sure it started with the latest version of Wordpress or not.

My Dashboard became completely useless. It’s like it’s showing me a flashback of a Dashboard from a few days or hours ago:

  • Comments I’ve deleted in the Dashboard (hitting “trash”) are suddenly back there, awaiting my moderation.
  • Plugins I’ve deactivated or even deleted are all back there and according to Dashboard still running (while in my FTP folder they’re certainly gone).
  • The plugin page cannot be trusted anymore as it shows some plugins are activated that aren’t and vice versa. I have to check on my actual website to confirm which ones are running.
  • Updates aren’t shown correctly. Once I’ve updated a plugin, a few minutes later it shows me again that there’s a new update.

As you can tell it’s all pretty much the same phenomenon. It’s as if I’m seeing an older version of my Dashboard.

Not sure what else is broken. The only other thing I noticed is that even on my actual blog I still see a comment. Blog post says “1 comment”, but the actual comment doesn’t show up.

At first, this all sounds like a “cache problem”. But I’ve already turned off all caching:

No caching plugin installed

  • Turned off server caching via htaccess
  • Disabled leverage browser caching
  • Emptied my own browser cache

Other things I tested:

  • Turn off all plugins.
  • Switch to the standard Wordpress theme “Twenty Twelve”
  • I tried WP_DEBUG, but nothing related shows up.
  • I manually re-installed the newest Wordpress version as described on Wordpress.org (replaced the core files, wp-admin and wp-includes folders).
  • I researched the internet, but nobody has described a similar problem, so I suppose this is not a common Wordpress issue.

The issue remains.

Unfortunately I’m not a developer and don’t know too much about the Wordpress codex etc. But to me it sounds that the mistake is definitely not in the plugin or theme folder. The problem is that I’ve reached the point where I really cannot turn off plugins via Dashboard properly anymore. It’s so annyoing!

My questions are:

  • Not the plugins, not the theme, not the core files, what else could it be then? (wp-config.pho or htaccess maybe?)
  • Should I try installing an earlier version of Wordpress?
  • This all sounds so much like a caching issue. I know my host (HawkHost) is running a server caching (or whatever it's called correctly). Maybe they've changed something and this could be the cause?
  • Any other suggestions?

The way my Dashboard is right now, I really can’t use it. Please advice!

  • Oh, was there a password somewhere? I didn't notice. I'm not good with that stuff, so I'd just to a new clean Wordpress install? How would I even create a new developer site. Do I need to use a subdomain? I have asked my hosting provider to check. Thanks. – japanworm May 1 '17 at 14:53
  • Sounds like a permissions issue. It could have to do with lines 72-80 in your .htaccess file. I would remove them, clear all caches (server and browser) and see if that helps. – WebElaine May 1 '17 at 18:08
  • @WebElaine Thank you, I'll try. I also found something else that is weird: "Your URL performed one redirect! While redirects are typically not advisable (as they can affect search engine indexing issues and adversely affect site loading time), one redirect may be acceptable, particularly if the URL is redirecting from a non-www version to its www version, or vice-versa. from: zoomingjapan.com/travel/ise-shrine to: zoomingjapan.com/travel/ise-shrine" Why would my site redirect .. plus to the same URL? I haven't given the command anywhere? :/ – japanworm May 1 '17 at 18:41
  • WP typically redirects to preserve a trailing slash. In your example there the URL is not quite the same - it redirected from /ise-shrine to /ise-shrine/ with a / at the end. – WebElaine May 1 '17 at 18:56
0

I contacted my host service again. They just gave me the same line to insert into my .htaccess file and I told them I already tried it and it didn't work.

I then showed them my .htaccess file and they deleted the whole part that concerned their server caching. Now server caching is completely off and everything works again.

Still not sure why this previously never caused issues. In the end, it had nothing to do with Wordpress.

I hope this answer will help people who run into similar problems.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.