I'm having some issues with setting my Wordpress and site URL to the https and www version. I'll use example.com, instead of my actual site address, but here is the gist of my issue:

I had my Wordpress URL and site URL set to http://www.example.com. A few days ago, I installed W3 Total Cache and Cloudflare (as a W3 Total Cache extension). Since Cloudflare provides a free SSL, I wanted to default to the https version of the site. So, I went into the Wordpress general settings and changed the Wordpress and site URLs to https://www.example.com

After that, I got "too many redirects" errors in Chrome and could not sign in to the wp-admin area. I reset the Wordpress and site URLs by adding these lines to my functions.php file:

update_option( 'siteurl', 'http://example.com' );
update_option( 'home', 'http://example.com' );

I can now log in to the wp-admin area and I have removed those two lines from the functions file; however now, if I even change the Wordpress and site URLs to add the www, I get the "too many redirects" error and cannot get into the wp-admin area.

So, I'm kind of lost at this point as to how to get the www back, let alone how to add the https to the General Settings. I don't know if this has anything to do with the W3 Total Cache or Cloudflare plugins; but, I didn't want to try deactivating them because I only have the SSL as a part of Cloudflare.

As a side note, I also cannot connect to my site in FileZilla, since my initial attempt to change the URL (even as I can now access wp-admin with the URLs set to http://example.com). I have no idea why that is. But I can access the files from within my host's CPanel, so I can make changes there.

  • These issues were due to Cloudflare. I deactivated W3 Total Cache (and thus the Cloudflare ext.) and then I was able to add the 'www' back to my site URLs. However, upon re-activating the plugins, I am faced with the common issue of mixed content warnings, only on dynamic images (i.e., those associated with Wordpress posts). I think I can solve this by using a plugin (SSL Insecure Content Fixer), but I'm hoping that there is a non-plugin method. There might not be, since Cloudflare suggests not changing the site URLs within Wordpress (and I still cannot do that, anyway) but, I'll keep looking. – JCM May 1 '17 at 14:47
  • sorry for the noise, but downvoting and close voting to remove the question from the "open questions" list as it is a plugin/cloudflare related problem – Mark Kaplun Aug 14 '17 at 5:10

I do have the same problem when I am using Cloudflare SSL.Just make redirection to https for all pages using CloudFlare dashboard and then install Really Simple SSL and check only "Auto Replace mixed content".

Hope this may solve your problem.

If else try deleting .htaccess file.

Not the answer you're looking for? Browse other questions tagged or ask your own question.