3

I am using Cloudflare (service that gives free HTTPS for your website) to have https on my Wordpress website but when I change the site URL and Wordpress URL to https://, I get a "redirected you too many times" error.

I also tried to add define('FORCE_SSL_ADMIN', true); in the wp-config.php file and guess what? The same thing happens again. I'm not sure what I am doing wrong but your help would be greatly appreciated...

I tried this solution but it doesn't work but returns a 500 internal server error instead.

  • Did you setup AWS to send requests to HTTPS? – Greeso Apr 30 '17 at 15:57
  • Hi, Welcome to WPSE. This question has been asked a lot of times before. I have an answer to this question here. – Jack Johansson Apr 30 '17 at 16:12
  • Could you please elaborate on using Cloudflare ? What exactly are you trying to do and how do you expect it to interact with your WordPress site? – Rarst Apr 30 '17 at 17:16
  • @Rarst Yes, I created an account with Cloudflare to have https on my Wordpress website but when I change the settings of the website url to https:// it enters an infinite loop of redirects... – Toufic Batache Apr 30 '17 at 17:26
  • 1
    That just repeats what you stated in question. Assume others have no clue what Cloudflare is and what it has to do with https, this is important and missing context for people to grasp what is going on and do they have an idea that might make an answer. – Rarst Apr 30 '17 at 17:30
3

I have recently solved my issue, I went on wordpress support, found my issue and how to fix it. I installed the SSL Insecure Content Fixer plugin and chose in the plugin settings for SSL Detection, the setting that was recommended. Then, I went to the settings and set my Wordpress and site URL to https://. This all together fixes the infinite redirect loop.

1

What you can do is try to go to settings --> General and and change your Wordpress address site to a non-www URL if it has a www in it. Also, do not include a slash at the end.

One more thing, if you have any plugins activated, disable all of them and enable them one by one and see if any of them are causing an error.

  • Thank you but I have already solved the issue. My settings are already like you said they should be... – Toufic Batache May 1 '17 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.