0

I have a wp site that was working on a dev server on port 8082. After we decided the site is done, we transferred it to another server. However something in the site redirects to 8082 despite the fact that the nginx configuration is pointing to 80. This is madness. I've tried to point it to another port i.e. 8085 but it still reverts back to 8082 and times out because the nginx is not configured on that port. It is a clean WP install with one of the default themes and there are no plugins.

I have also tried to put the bellow eddits to wp-config.php

define('WP_HOME', 'http://example.name');
define('WP_SITEURL', 'http://example.name');

And eddied the siteurl and and home fields into the wp_options table but the site still redirects to port 8082

Any suggestions?

  • Usually after changing a port it's customary to restart the httpd server – codiiv Apr 21 '17 at 20:31
  • That is what I did. This is a very unique case. I administer Linux servers for several years I've seen nothing like this, pure madness .. – Spirit Apr 21 '17 at 20:32
  • Did you transfer the site to another server or it's a clean install? You mention both. Does it redirect you immediately from any URL or after you followed any link? Do you use a caching plugin? Nothing is clear from you question. – Max Yudin Apr 22 '17 at 13:15
  • What is the home page URL in Settings | General. Have you added a port to it there? Perhaps your .htaccess file is doing some rewriting. Also check wp-config.php. – Admiral Noisy Bottom Feb 2 at 5:20
0

You can take a look at my answer here :

Stackechange redirects all pages from new domain to old domain

Otherwise check the .htaccess files also

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.