0

I recently updated WP and some plugins and now I get this on all of my related product tabs. I know it says "Try: $product->get_type();" but I'm confused on where I should replace the old version with this version. It seems to be using "$product->product_type;" and says that it shouldn't be called directly.

I'm lost on this one.

  • It should say what file and line that error is on. – ngearing Apr 18 '17 at 23:34
  • And if its coming from a plugin, you should let the plugin author know. – ngearing Apr 18 '17 at 23:35
  • Sorry, it's on line 4137 of wp-includes/function.php, which just shows the trigger message. But nothing else or any explicit error – H.Norman Apr 18 '17 at 23:42
  • I see, do you have any custom Woo templates in your theme that need to be updated? – ngearing Apr 19 '17 at 0:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.