1

I have my wordpress server set up using php, mysql, and apache on my raspberry pi. I also have a dynamic dns hostname and configured my router's port forwardiing settings.

When trying to access my server from outside of my local LAN, when I type in my dynamic dns host, (for example, my phone on 4G mobile network or at school), the site incorrectly redirects to the server's local IP address: 192.168.0.18 so the page fails to load up.

This is very weird because I also have owncloud set up on my pi and in the same condition I try to access mydynamicdnshost/owncloud, it doesn't redirect me to local IP and the page loads up successfully.

I know this is a really basic problem with wordpress configuration but I simply cannot fix it. So does anyone know that please answer my question. Many thanks!

0

Change the Site URL in Options Table.

UPDATE  `wp_options` SET  `option_value` =  'YOUR_SITE_URL' WHERE  `option_name` = 'siteurl' OR  `option_name` = 'home';

Also change the static URLs in your post content.

UPDATE `wp_posts` SET `post_content` = REPLACE(post_content, '192.168.0.18/YOUR_LOCAL_SITE_URL/', 'YOUR_SITE_URL/');

Don't forget to change the table prefix if its not 'wp_'.


Edit : Access PHPMyAdmin of your server. Contact your Hosting Provider if you are not aware of this.

Select your WordPress Database & Access wp_options table. And change 'siteurl' && 'home' attribute values to your Live Website URL.

Hire a developer if you are not sure what you are doing !

enter image description here

  • I am sorry, could you please tell me which file contains those configurations? I'm a completely newbie to this field. I tried to find them in wp-config.php, etc but none of them were found. – tunan guo Apr 11 '17 at 7:59
  • These settings are exposed on the Settings / General page too, as WordPress Address (URL) and Site Address (URL). This Codex page provides more information. But I'm not sure that the answer will work; I'd think that you need to update these settings to the dynamic hostname you're using, not to the local address. – MrValueType Apr 11 '17 at 9:53
  • Updated the answer. – JItendra Rana Apr 11 '17 at 10:45
  • @GaborBarat Agree, That the approach given i this codex page is better than my solution. But if its not done properly it will change the site and home url in options table on each and every request. – JItendra Rana Apr 12 '17 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.