1

I decided to change the option on wordpress > posts > screen options > show posts to 999.

now the page crashes when i open it .

it loads for a little bit and then it crashes. how can i undo the changes . please help.

4 Answers 4

4

That option is held in the wp_usermeta table with the edit_posts_per_page meta key.

Using PhpMyAdmin (or straight up MySQL) you can make that change for your specific user.

User Meta to change

Some notes of caution:

  1. Depending on the number of users on your website, there will likely be more than one edit_posts_per_page meta key available. Make sure you change the one that corresponds to the correct user ID.
  2. DO NOT CHANGE umeta_id, user_id, or meta_key. BAD THINGS COULD HAPPEN.

It probably goes without saying, but wherever possible options should be changed via the WordPress interface with a fall back of editing the database directly in cases like yours where WordPress (really it's the server memory) just can't handle the load ;)

2
  • Interesting. This option doesn't exist for me. Is it created only if you change the default value?
    – Johansson
    Apr 7, 2017 at 18:37
  • I believe by default that value is 20, so it might not exist if a user doesn't change it. But if you do change it (even if you change it back) it will for sure show up. Now your table prefix might be different, so look for that table in the {prefix}_usermeta table :)
    – Ian
    Apr 7, 2017 at 18:39
2

I'm on the same problem and I can't find the meta_key edit_posts_per_page on wp_usermeta table.

The problem happens when I try to see Products on Woocommerce.

Edit:

I found the solution myself, for Woocommerce Products:

  • table, 'wp_usermeta'
  • meta_key, 'edit_product_per_page'
  • meta_value, change to '20'

edit_product_per_page

If it still doesn't work maybe you will need to clear all caches TOO.

0

If you have access to your phpMyAdmin panel, you can easily reset this manually inside your database.

[edit] as pointed out by Jack Johansson, I did not read the question carefully—my earlier value was incorrect.

3
  • That number belongs to the number of posts per page for the blog's front page, set in Settings > Reading.
    – Johansson
    Apr 7, 2017 at 18:21
  • you guys are awesome . thank you so much . another thing one can if someone else comes into this predicament. is when you open posts . and while it is trying to load the 999 posts . quickly click on trash which might have 0 post. from there i click on options again and lowered it there to 50. and now its working
    – Mike Han
    Apr 7, 2017 at 18:27
  • @MikeHan Did this answer work for you? I thought you want to change the option in the post edit screen.
    – Johansson
    Apr 7, 2017 at 18:35
0

I'm not sure if this has been updated since or is this is based on a different configuration or hook, but for me the meta_key value to change is edit_post_per_page

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.