2

I've set up a subfolder multisite. Main site: https://cs-amx.org/ Subdomain site: https://cs-amx.org/chypre

You see the maintenance screen is well displayed on the main site, but not on the subdomain site.

All the themes and plugin files lead to a 404.

For example, cs-amx.org/chypre/wp-content/plugins/maintenance/load/style.css doesn't load.

But cs-amx.org/wp-content/plugins/maintenance/load/style.css works well.

The admin panel at cs-amx.org/chypre/wp-admin/ works, though.

Here's the content of the .htaccess file:

# BEGIN WordPress
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]
# END WordPress

Any idea?

1

The .htaccess looks fine. It is exactly like the one I have. Do you have any .htaccess files inside /wp-content/ or /wp-includes/ or one level up from the main site folder?

Also try deactivating all plugins.

I also found this topic that seems to be for the same issue. From what I read, there was a situation caused by hosting security measure in which the .htaccess file was not used and it was needed to do changes in the apps/wordpress/conf/http-app.conf file. This is the exact post I am talking about.

  • 1
    The issue came from Ngninx. Thank you for your reply, it helped me fixing the issue. – Gaston Flanchard Apr 1 '17 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.