0

Server upgrading Friday, which will kill my existing WP 3.1 blog. So I’m installing 4.7.3 fresh in new subdirectory of existing WP 3.1 domain/site AND using the same database. Domain is a subweb. Server is running PHP 5.3. (New one will run 5.6) Once working, I’ll point the domain at the new directory. (Not sure whether subweb/shared db might affect this?)

I did mod the wp-config file with db info and memory use limits. Other than that, the entire install is fresh out of the box. No theme files here other than those included with 4.7.3 (although the old blog is running Thesis 1.8). No plugins other than stock akismet.

Got the following errors:

Warning: require_once(/users/domain.com/htdocs/directory/new subdirectory/wp-load.php) [function.require-once]: failed to open stream: No such file or directory in /users/domain.com/htdocs/directory/new subdirectory/wp-admin/install.php on line 36

Fatal error: require_once() [function.require]: Failed opening required ‘/users/domain.com/htdocs/directory/new subdirectory/wp-load.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /users/domain.com/htdocs/directory/new subdirectory/wp-admin/install.php on line 36

Looking at the newly installed subdirectory, I saw ONLY folders:

wp-admin
wp-content
wp-includes

Next I tried uploading all files again. Same thing. So I selected the following files (without also selecting the above-named directories) and uploaded:

index.php
license.txt
readme.html
wp-activate.php
wp-blog-header.php
wp-comments-post.php
wp-config.php
wp-cron.php
wp-links-opml.php
wp-load.php
wp-login.php
wp-mail.php
wp-settings.php
wp-signup.php
wp-trackback.php
xmlrpc.php

And I get a nearly identical error msg:

Warning: require(/users/domain.com/htdocs/directory/subdirectory/wp-includes/load.php) [function.require]: failed to open stream: No such file or directory in /users/domain.com/htdocs/directory/subdirectory/wp-settings.php on line 19

Fatal error: require() [function.require]: Failed opening required ‘/users/domain.com/htdocs/directory/subdirectory/wp-includes/load.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /users/domain.com/htdocs/directory/subdirectory/wp-settings.php on line 19

No idea what's going on here, hoping to learn how to fix it.

Any help appreciated!

1

It could be 2 things

Most like it's your file permissions. It is probably that your apache isn't able to open the files set files to 0644 and directories 0755.

The other problem could be your php version. Since you are upgrading to a new server, why not get the php in version 7? php 5.6 hit end of life 2 months ago.

  • Thanks for the quick reply! Will ask about file permissions. As to PHP, I believe WP 4.7.3 is supposed to be compatible with 5.2+ so (I'm guessing) that shouldn't be an issue? Host server upgrading. Could be what they mean is lowest compatible PHP is 5.6, not sure but will ask. – jomar Mar 28 '17 at 21:39
  • Host server upgrading to PHP 5.6, all I know there. Host engineer just tried 0644 and 0755 with no problems. Any other likely suspects? – jomar Mar 28 '17 at 21:49
  • What do you mean just tried? Did he leave those permissions? What is site address? – rudtek Mar 28 '17 at 21:51
  • makeyourbookamovie.com is the current blog (makeyourstoryamovie.com redirects there). It's a subweb of johnrobertmarlow.com. The new subdirectory within makeyourbookamovie.com is /mysam Host is domaindiscover / tierranet Not sure what you mean by "Did he leave those permissions..." Thanks! – jomar Mar 28 '17 at 21:58
  • NEW INFO: Tried the same WP 4.7.3 install in another subdirectory but using a NEW db--no problem. Using the old db is the issue. NEW QUESTION: Can I get all post / page / comment info from the old db and put it into the new, so I don't have to rebuild the entire blog? Thanks for any help! – jomar Mar 28 '17 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.