1

in this thread i want to describe what to do if WordPress asks you for your FTP details if you want to run Automatic Updates/Upgrade Plugins - what to do to stop this!?

I run wp for more than 3 years now: In some cases, we are not able to update/upgrad either the WordPress and the plugins to a newer version without providing the FTP connection information. In other words - it fails - it does not succeed. To be frank - I have pulled my hair - and have read hundreds of help pages.

I have found out that this is a common issue whereby the WordPress background code system can’t write to the /wp-content folder directly. In other words - we have to take care for this processes.

Some folks suggested an quick fix and a hack: i want to share the insights - i want to discuss if you have made similar experiences and i would love to know what you have done to solve the issues.

We need to do some checks to make sure - what goes on our sever: - in the folliwing i will share the ideas that may help to fix the issues. I want to share ideas bout checks:

Step 1.: The first check is to make sure whether on the server the module SuPHP is enabled or not in the server You can do so by using the following command for your Controll Panel on the server: Please run this code: [note that is only a little code - but it helps us a lot]

=============
/usr/local/cpanel/bin/rebuild_phpconf --current
=============

You did it: you have made some progress - hey then youre happy.

Step 2: You run on Plexk or some kind of Directadmin control panel, then you have to make sure to do some other checks: check by putting the following code lines in phpinfo.php file or info.php file in the document root of any domain.

Do like so - just run this code:

==============
<? phpinfo(); ?>
==============

Step 3: If you have some special server conditions then we need to do the following:

If on your server the SuPHP is not enabled then you have to make sure to enable it. I can promise that this helps you a bit further.

Fixes without changing php handlers fron DSO to SuPHP ::

Step 4: If all does not help so far just go further and do some of the followning we have some fixes : go to your server and do some checks:

Do some investigative work and try to locate the WordPress root diectory then afterwards try to find the “wp-config.php” file. If you have found it then go futher and edit exactly this little file and insert some lines: You have to do some editing-work - this is not too hard for you. just go ahead: you have to do some editing in somewhere of the middle of the file - as it’s own block, normally put it after the following phrases

mysql username/password block.

==================================
/*** FTP login settings ***/
define("FTP_HOST", "localhost");
define("FTP_USER", "yourftpusername");
define("FTP_PASS", "yourftppassword");
==================================

Well - so far so good: if you have done this - then we can go ahed: You may want to change "yourftpusername" and "yourftppassword" to the actual FTP usernames/passwords for the website.

===================================

We have another little tiny fix

We have some more methods to do a fix: a alternative way to deal with this; do some change of the constant, FS_METHOD in the wp-config.php file. Well to be honest this does some special thing: it bypasses WordPress’s recurring prompts, and then it allows auto-updates of the files that you want to add.

So we see: it takes only one little line of code to do this.

In other words: just do like so; Open /Wp-Config.Php and then you go ahead and do some pasting : Paste the following code to the wp-config.php file, - just go to the following entity - look for the following line: every other line of code.

==============
define('FS_METHOD','direct');
==============

i love to hear from you - just write some lines and tell me how your experence is!?

What does help you - and what not!?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.