1

it's likely I missed something, but I just tried to use wp-cli to install Wordpress on a subdomain.

After succesfully downloading, creating wp-config and calling the install procedure with:

wp core install --url=http://sub.example.com --title=title --admin_user=admin --admin_password=password --admin_email=admin@example.com --skip-email

, I CAN open the new Wordpress-Site but all URL's seem to be wrong.

What should be: sub.example.com

is: sub.example.comexample.com

Probably the url is parsed "tld and then to the next dot" and I can repair the installation with:

wp search-replace sub.example.comexample.com sub.example.com --skip-columns=guid

In a way I can live with this, but it seems somewhat wrong to me.

Is there a better way like an extra parameter or something for wp core install?

| improve this question | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.