1

After months of leaving and deleting my WordPress site, I decided to try again. I downloaded the new version 4.7.3, installed and added a new post. So far so good.

I then went back to edit the post and the same error that I received before, cannot find the post; nothing to see here, message.

I cannot edit any new post that I create, but I can create a new post. The odd things are that I can modify the default message that is created on install by WordPress.

I deleted the database and the entire home directory multiple times. Deleted the .htaccess file and changed permalinks to no avail as well.

The setup is a fresh install with no plugins, no themes used except default. I tried switching between the different default also. Still, no dice.

Whenever I click the update, it returns a 404 error, page not found, as stated by Firefox dev tool. Add new does work. If I cick to edit a new post, it bring the page up in the editor. But as soon as I click update, 404 error.

This is the contents of the .htaccess file as by WordPress.

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Update

I just noticed in one of the logs this error when I changed the permalink to plain. [Fri Mar 24 06:15:46 2017] [error] [client xxxxxxxx] File does not exist: /home/domain/public_html/403.shtml, referer: domain.com/wp-admin/post.php?post=14&action=edit

Any ideas?

  • Have you tried debugging? Otherwise, if WP is causing trouble with a clean install, you may want to talk to your hosting provider. – cjbj Mar 24 '17 at 10:18
  • Are you hosting it your self or who is hosting it? – Nathaniel Sturtz Apr 29 at 18:58
0

You could try to reset the WordPress permalinks to see if this is causing the 404 error. Here is a useful article on how to reset your permalinks.

| improve this answer | |
  • Yup, already tried that and doesn't work. Im stumped. – nitefrog Mar 24 '17 at 10:11
  • Does the permalink shown on the WordPress admin section for the post match the one shown in the url when you try to view the page? – Chess Byte Mar 24 '17 at 10:17
  • Also, you could try disabling all plugins (If you have any active) to see if this is causing the issue. – Chess Byte Mar 24 '17 at 10:19
  • There are not plugin or themes. It is a clean install from scratch. Bare bones. – nitefrog Mar 24 '17 at 10:20
  • Okay, the only other suggestion I can think of is to look inside your WordPress database and check the permalink there. To do this, login to your WordPress database and run this query SELECT * FROM wp_posts WHERE post_type = 'post' ORDER BY post_type DESC --- Note, "wp_" before posts in the query should be what ever you inputted when creating the wordpress website. You can find the database prefix in the wp-config.php file. Once you have the lists of posts, you can check the "guid" collumn, make sure it's the same as the one you're trying to access when you get the 404. – Chess Byte Mar 24 '17 at 10:32
0

To do so .. You need to login to wordpress admin and then need to save the permalink again..

Just go to Settings >> Permalink

And save without doing any changes.. and that error should be gone..

| improve this answer | |
  • Again, tried that and it does not help. Error still here. 404 error. – nitefrog Mar 24 '17 at 10:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.