0

I'm following the "Building Themes from Scratch Using Underscores (2016)" tutorial on Lynda.com and at around 00:35 he suggests downloading the Theme Unit Test Data from WordPress. I've downloaded the xml file, but when I go to the dashboard of my WordPress site, then Tools --> Import --> WordPress, I'm prompted to install the WordPress Importer plugin because I haven't used it before.

This brings up a window that isn't shown in the tutorial:

enter image description here

Why am I being asked for Hostname, FTP Username and Password when my site is running locally with XAMPP?

There's a treehouse article that suggests going ahead and entering 'root' as the username, leaving the password blank, and finding your local FTP connection information in the XAMPP control panel (I'm assuming this is what you'd enter for Hostname). I can't seem to find 'Filezilla Admin' anywhere in the Control Panel (localhost/xampp - is this what he means by the Control Panel?)

enter image description here

Any ideas or suggestions? Thanks!

1

If your using a MAC you will need to set file permissions to allow for updating and downloading plugins/themes without the use of setting up the FTP and manually adding them into the htdocs folder.

The link below will walk you through this to set it up to work.

http://ghosthorses.co.uk/production-diary/auto-update-wordpress-plugins-on-localhost-xampp-on-mac-osx/

http://wpforce.com/auto-update-wordpress-xampp-osx/

This video will show you how to fix the permissions issue so that you can download plugins via Wordpress without manually adding them or using the FTP settings. https://www.youtube.com/watch?v=Jlg0BteNBKI

I would make a short cut to the xampp folder for your htdocs on your desktop this makes it quicker to get to your files.

Its also good to note that xampp when you update to newer versions can destroy your mysql databases so download them before you upgrade as this happened to me before I made the jump to MAMP.

  • Thanks for your response. Following the instructions in the link, I can't navigate to my home directory from the command line. XAMPP is clearly in my Applications folder i.imgur.com/TdBRDHc.jpg, but when I try and cd into Desktop/Applications/XAMPP, I get "no such file or directory" imgur.com/a/e9JUz. – HappyHands31 Mar 22 '17 at 20:33
  • 1
    Im not a big fan of xampp for the above reason and use Mamp instead. You need to change the permissions this will let you download and install without the FTP or manually adding plugins. I have updated the above the reflect the issue that will help you to fix this. – Sam Mar 22 '17 at 21:49
  • A couple things - Following in the instructions in your second link, using the terminal to open the httpd.conf document gave me an 'invalid option' error: i.imgur.com/m8oddcd.png. So then just opening the file manually with a text editor and searching for 'nobody' returned no results. I think I see where the article is talking about User and Group, though, (line 173 in my file) - they were both automatically set to 'daemon' (not 'nobody'). So then I changed them to 'mylocalusername' and 'nogroup'. I saved and closed the httpd.conf file, stopped Apache from Control panel and tried to – HappyHands31 Mar 23 '17 at 1:01
  • restart Apache, but Apache won't start: i.imgur.com/KIN5Hyl.jpg i.imgur.com/lM8qfnr.png. So that's where I'm stuck. I might try restarting my computer. – HappyHands31 Mar 23 '17 at 1:04
  • Restarted my computer and still nothing. I followed the instructions in http://stackoverflow.com/questions/27333203/xampp-couldnt-start-apache-windows-10 but I still can't start apache. This is insane. – HappyHands31 Mar 23 '17 at 1:23
1

What I needed to do was to go to the actual site for the plugin (wordpress.org/plugins/wordpress-importer/installation), download the folder, unzip the folder, and manually place the unzipped folder into the plugins folder of my theme, aka Applications --> XAMPP --> xamppfiles --> htdocs --> ThemeFolder --> wp-content --> plugins.

EDIT: This caused WordPress Importer to display "Run Importer" instead of "Install Now | Details" (screenshot), so it looked like it was going to work, but when I actually clicked on "Run Importer" I still get the error message: (screenshot).

EDIT 2: I needed to go into XAMPP --> xamppfiles --> etc --> httpd.conf. In this file I needed to change User to the username that appears when I run terminal commands (without the "$"). And then I needed to change Group to admin (I don't remember where I got admin from - but I will try to find it and follow up). So it will look like this:

User happyhands31
Group admin

I also needed to make sure that the port number in httpd.conf matched the port number in the Configure Apache Server. The line in the httpd.conf file (line 54 for me) needed to say:

Listen 80

Doing these things, combined with having an internet connection that doesn't interfere with the MySQL Database (it didn't start earlier and all I had to do was switch wifi a.k.a. move to a different building) finally got the Import WordPress plugin to work: screenshot.

  • You have the same issue this a files permission issue with XAMPP and Mac you will also have issues trying to upload images. Change the folders users permission by getting info and then at bottom of panel give all users full read and write permissions. – Sam Mar 23 '17 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.