-1

I am trying to use the plugin Ultimate CSV Importer to import a .csv file into WordPress custom posts.

I have set up the custom posts like so:

function codex_custom_init() {
    $args = array(
      'public' => true,
      'label'  => 'Schemes'
    );
    register_post_type( 'scheme', $args );
}
add_action( 'init', 'codex_custom_init' );

I am trying to import these columns from the .csv:

  1. Account Name
  2. Contact 1
  3. Email

Account Name is to be imported as the post title.

I have set up two fields in ACF to store the other info:

  1. Email (email)
  2. Contact 1 (contactname)

I can get the Email field to import fine sometimes (but not every time... though I'm unsure what / if I'm doing anything different those times), but the contact field isn't having any of it.

enter image description here

Notice how Contact 1 has a different field name. This is because the importer wasn't working originally... I thought maybe the space character was causing problems... so I tried with an underscore but no luck... I also thought maybe the number was creating issues, but no luck changing that either.

So I ended up just picking a different name — contactname but that didn't work either.

The meta value for that field isn't showing either in WordPress (under the ACF section of the post edit screen) nor is it entering the database.

1

Fixed it, I renamed the column Contact 1 in my .csv to just Contact... I think the space / number must have been messing with the plugin

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.