2

I have recently setup a Linode Apache2 Debian server and I am hosting my WordPress site on it. It seems I can only connect to the server with SFTP.

When I attempt to add/update a plugin I am presented with this screen:

enter image description here

There doesn't appear to be an option to use SFTP instead of FTP or FTPS. I cannot find any plugins or anything to do this.

Because of this, I cannot add/update plugins.

What are my options?

2 Answers 2

3

Looks like a permissions issue:

sudo chown -R www-data:www-data /var/www
1
  • ...and leave your front door unlocked. And write the pin number for your credit card on post-it note and stick it on the back of the card.
    – symcbean
    Sep 19, 2019 at 11:14
1

I use SSH SFTP Updater Support and it works fine. From the project description:

"SSH SFTP Updater Support" is the easiest way to keep your WordPress installation up-to-date with SFTP.

5
  • the plugin wasn't updated for 2 years, probably unmaintained Mar 13, 2017 at 10:48
  • Actually it's the only sftp plugin and I use it since years without problems. So right now, I don't see a different solution.
    – geraldo
    Mar 13, 2017 at 13:15
  • for me the question is stupid. the different solution is either do it the slow way, use wp-cli or just setup an ftp server with only local access. installing some thing that is not maintained is just not a good security practice especially in security oriented plugin Mar 13, 2017 at 16:29
  • I have to agree with @MarkKaplun, out of the presented options, I would go with the wp-cli, but unfortunately my requirements mean that the plugins need to be managed via the CMS Mar 14, 2017 at 9:24
  • 1
    The mentioned plugin is supported again, so I maintain my recommendation.
    – geraldo
    Sep 21, 2019 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.