0

I'm trying to get my blog to work with the auto-updates, after recently getting hit with a "hack" where someone overwrote an article (nothing too malicious, but we lost the article). The problem is that the auto updates don't seem to work.

I'm not sure if this is related, but I get this error on the dashboard:

RSS Error: WP HTTP Error: cURL error 6: Could not resolve host: wordpress.org

Running via command line connects fine:

curl --head --insecure -v http://planet.wordpress.org
* Rebuilt URL to: http://planet.wordpress.org/
* Hostname was NOT found in DNS cache
*   Trying 66.155.40.250...
* Connected to planet.wordpress.org (66.155.40.250) port 80 (#0)
> HEAD / HTTP/1.1
> User-Agent: curl/7.38.0
> Host: planet.wordpress.org
> Accept: */*
>
< HTTP/1.1 200 OK
HTTP/1.1 200 OK
* Server nginx is not blacklisted
< Server: nginx
Server: nginx
< Date: Tue, 07 Mar 2017 06:51:04 GMT
Date: Tue, 07 Mar 2017 06:51:04 GMT
< Content-Type: text/html
Content-Type: text/html
< Content-Length: 174858
Content-Length: 174858
< Connection: keep-alive
Connection: keep-alive
< Vary: Accept-Encoding
Vary: Accept-Encoding
< Last-Modified: Tue, 07 Mar 2017 06:45:10 GMT
Last-Modified: Tue, 07 Mar 2017 06:45:10 GMT
< X-Frame-Options: SAMEORIGIN
X-Frame-Options: SAMEORIGIN
< X-nc: EXPIRED lax 250
X-nc: EXPIRED lax 250
< Accept-Ranges: bytes
Accept-Ranges: bytes

<
* Connection #0 to host planet.wordpress.org left intact

Curl seems enabled to me in phpinfo();

enter image description here

I installed the "Update Tester" plugin, and I get:

PASS: Your WordPress install can communicate with WordPress.org securely.
PASS: No version control systems were detected.
FAIL: Your installation of WordPress prompts for FTP credentials to perform updates. (Your site is performing updates over FTP due to file ownership. Talk to your hosting company.)

As a side note, plugin installs / updates work fine without the FTP information (i.e I can install them with simple clicks, instead of having to enter my FTP logins), so I'm a bit baffled as to why the auto-update doesn't work (and the curl issue)

Any suggestions are much appreciated!

1

I had the same problem and eventually found a solution today (actually, a friend of mine did it). What I did was to edit the /etc/nginx/nginx.conf file and add resolver ip address. The configuration file in the section server contains now resolver 127.0.0.1; below you can find a part of it

server {
    listen       443 ssl;
    resolver        127.0.0.1;

Do not forget to restart nginx and php-fpm services, that depends on your distro, with archlinux you can do the following

systemctl stop php-fpm
systemctl stop nginx
systemctl start php-fpm
systemctl start nginx

Hope that helped.

  • You star - that got rid of my curl errors :) Still doesn't fix the "update" issues I've got, but I'm just going to leave that for now and do the updates manually. Not exactly like its super hard to update WP manually =) (just would have been nice to get it to do it without any interaction) – Andrew Newby Mar 13 '17 at 19:33
  • 1
    Glad to hear that the main problem is fixed, maybe someone will explain what caused troubles, a few days ago wp worked without resolver set – pml Mar 14 '17 at 5:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.