1

I have a new WordPress and I added a page:

/fr/les-solutions

And I can see the permalink properly in the backend editor. However, when I click on the link, it redirects me to:

/les-solutions/

I've tried to re-save the permalinks and nothing has changed. Anyone know why it's removing the language slug from the url?

Update

My language URL format setting is set to Different languages in directories and I checked the Use directory for default language. and for the Root Page, I've chose the option A Page.

  • Hi! Have you tried "re-booting" your WordPres slugs? Just go to "Settings > Permalinks" and hit the "Save" button so WordPress re-generates it's permalink data... – MacPrawn Feb 27 '17 at 20:59
  • @MacPrawn Yes I've tried it many times. The permalinks in the backend shows up properly though. – Chin Leung Feb 27 '17 at 21:08
  • Hmmm - yes, they still would show ok on the back-end... Have you checked your .htaccess file? Any strange non-WordPress rules in there? – MacPrawn Feb 27 '17 at 21:11
  • @MacPrawn Nope the .htaccess is the raw one of WordPress. – Chin Leung Feb 27 '17 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.