0

We have developed many blogs on wordpress which is hosted on Rackspace server(Red Hat). Last Sunday we worked on user and set 'myuser' to run as PHP. So if we execute

echo shell_exec('whoami'); then the result will be 'myuser'.

Before this, the PHP is running as apache user. So now we changed this to 'myuser'

Only after this changes, A lot of apostrophes and a some characters or letters have converted.

My MySQL and WordPress charset are unchanged. So everything were just perfect before the above mentioned changes.

And now I am fixing this by going through each and every posts manually.

What could be the problem? And how we can fix this?

Please see the image below:

enter image description here

0

Still no idea that why and how this happened all of sudden. But here is the 2 Solutions I found which is working: Applying anyone will work

1. Comment these two - //define('DB_CHARSET', 'utf8') and //define('DB_COLLATE', '') 2. Use Latin1, ('DB_CHARSET', 'latin1')

However, I am suspecting some attacks on our sever where blogs are hosted and investigating into this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.