1

I'm in the process of migrating an existing WP site to Cloudways and every time I try to edit a page the editor is blank and there's a brand new blank revision auto-saved. (Thankfully not published.)

The "current revision" is still set to revision that contains content... so it's been a real pain copying the data from the database and pasting it back into the editor... just to change or edit existing content.

All plugins are currently disabled and the behavior still persists. :/

  • Do you use a default theme? – Max Yudin Feb 23 '17 at 8:26
  • I was using a custom theme, the switched to twenty seventeen, then to another custom theme and finally to twenty sixteen... with no success. – Squish Feb 23 '17 at 13:21
0

The problem turned out to be the transition from utf8 encoded databases to utf8mb4.

Apparently the editor was getting a silent error and defaulted to dropping the transaction.


The Solution: Recently Wordpress has started switching to using utf-8mb4, so most people probably need to change their charset <meta charset="UTF-8" to <meta charset="UTF-8mb4">. Very old and out of date blogs may need to convert from latin1.

Most of the time your meta tag is filled in using bloginfo( "charset" ), which is pulled straight from your database, specifically your wp_options table.

‘charset‘ – Displays the “Encoding for pages and feeds” set in Settings > Reading. This data is retrieved from the “blog_charset” record in the wp_options table. Note: this parameter always echoes “UTF-8”, which is the default encoding of WordPress.

Therefore you can open your database and change the field, if you'd like. From UTF-8 to UTF-8MB4.

Or you can just hack it into your theme like so...

<meta charset="<?php bloginfo( 'charset' ) ?>mb4">

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.