0

After a recent WP update I get this error message in the back-end. Front-end is working without issues:

Fatal error: Call to a member function add_filter() on array in /... /wp-includes/plugin.php on line 111

I already tried updating WP manually but the issue persists. Ideas anyone?

  • Can you please copy the code from the php file that is causing the issue? line 111, and preferably a few lines before and after. – Jack Johansson Feb 20 '17 at 15:42
  • This is line 106 to 113 function add_filter( $tag, $function_to_add, $priority = 10, $accepted_args = 1 ) { global $wp_filter; if ( ! isset( $wp_filter[ $tag ] ) ) { $wp_filter[ $tag ] = new WP_Hook(); } $wp_filter[ $tag ]->add_filter( $tag, $function_to_add, $priority, $accepted_args ); return true; } Line 111 is this $wp_filter[ $tag ]->add_filter( $tag, $function_to_add, $priority, $accepted_args ); – Michael Oeser Feb 20 '17 at 15:51
  • OMG the formating is horrible... – Michael Oeser Feb 20 '17 at 15:53
  • I made a screenshot...sorry link – Michael Oeser Feb 20 '17 at 15:54
  • No problem. you can use ` to start the code and ` again to end code formatting. – Jack Johansson Feb 20 '17 at 16:01
0

According to the official support thread, you can:

  • Check out if you have the latest version downloaded and installed on your website. Head over to My Account -> Downloads on your WPML account.
  • If you need help updating, you can check this out.
  • If none of the above helped you, consider submitting a support ticket on the WPML support forums.

Now that we are off the official guidelines, we can stick to our own methods.

Try disabling the WPML plugin via ftp, or fully move the folder to somewhere else just to see if you can login to back-end.

If you can't use ftp, you can use WordPress command lines to deactivate the plugin.

After that you can login to back-end and install or update the WPML plugin to resolve the issue.

  • Yes I have the latest version of WPML. Anyway I deactivated the plugin via FTP but the issue still persists. I can´t use my back-end and now that the WPML plugin is deactivated also the front-end looks like a total mess :-( – Michael Oeser Feb 20 '17 at 18:38
  • @MichaelOeser You can enable it again via WPCL. The problem is because of WPML anyway. If this general guide didn't help, perhaps you should submit a ticket there. – Jack Johansson Feb 20 '17 at 19:52
  • I removed all plugins and was able to enter the back-end. WordPress was updated to the latest version and I re-activated most of the plugins incl. WPML. No issues whatsoever. So WPML seems NOT to be the bad guy. Seems as if exec-PHP causes the issues (which hasn´t been updated since several years) – Michael Oeser Feb 21 '17 at 7:15
  • Good to hear you could fix it :) – Jack Johansson Feb 21 '17 at 8:11
0

Yes, this is a WPML problem. For everybody who needs to fix it without updating WMPL there is a way.

Just rename:

/wp-contents/plugins/installer

to

/wp-contents/plugins/_installer

Then the Problem goes away. Ok, it's a hot fix but it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.