I have a little problem with my self hosted wordpress blog.
the problem is it keeps truncating my feeds even when I have chosen not to in the settings page.
one thing to bear in mind is that I use <!--more--> tag in almost all of my posts. I was wondering if it's because of that or something else?!
any help would be awesome.

  • Do you have any plugins installed that might be touching your feeds?
    – Manzabar
    Aug 12, 2011 at 15:12
  • @Manzabar I don't think so. I even installed the Full Text Feed plugin but it doesn't do any good!
    – 2hamed
    Aug 12, 2011 at 18:00
  • According to Full Text Feed's homepage, that plugin isn't needed in WordPress 2.5 (and presumably past that). You are running the lastest version of WordPress (3.2.1), right? Also, if you're not sure about plugins altering your feed, consider disabling all of them and then recheck your feed.
    – Manzabar
    Aug 12, 2011 at 19:09
  • I have disabled all the plugins and still the problem remains.
    – 2hamed
    Aug 14, 2011 at 6:17

2 Answers 2


Make sure you check the page source of your feed - some browsers will not show the full feed when looking at it raw (as the plain XML file) when using your browser to view http://yourdomain/feed

If you look at the raw source the full text should be found in under the "content" tag - Firefox for example will only show the "title" "link" and "description" but hide the content. IE will show the full feed in the browser.

Also make sure the full feed is set in the wordpress settings


Could also be something your theme is doing. Does you theme have an options panel, with an option related to RSS feeds?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.