0

I had to reinstall the website. However images in post galleries do not display.

  1. Exported all data in .xml.
  2. Installed fresh Wordpress.
  3. Reinstalled theme.
  4. Imported all posts and data.
  5. Manually via FTP copy pastade wp-content/uploads folder.
  6. All my posts contain WP galleries.

The problem: images do not appear in posts, even though they are located in the uploads folder. My permalinks did not change as it is the same url. Media library shows as empty.

How do I solve this and reconnect images with post?

Thanks, Rokas

0

I am assuming you used the Wordpress Importer? Did you select the "Import images" option? I think this would solve your issue.

To clarify on the issue: Your images were not imported in the wp_posts database. They are stored in there as an "attachment" post type. The WP Gallery Shortcode references the id of each of those entries to build the gallery. Your media library also displays the images based upon the database. Wordpress doesn't just detect images in the uploads folder

0

The order is wrong try this order:

  1. Exported all data in .xml. (you checked all content right?)
  2. Installed fresh Wordpress.
  3. Reinstalled theme.
  4. Manually via FTP copy paste the wp-content/uploads folder.
  5. Imported all posts and data.
  6. All my posts contain WP galleries.

when using the built-in tool for import/export of WordPress make sure are the resources are present before importing, because WordPress will not set/create the relation (db -> resource) if the resource doesnt exists.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.