1

I am currently using the GeoDirectory add-on for Wordpress and as of late, I haven't made any changes to Wordpress other than the fact that wordpress has upgraded to the latest version.

When I add an event, without a package then JQuery appears to be working fine, everything on the page appears and works the way it should so the link it like...

wp-admin/post.php?post=0000&action=edit

With that link JQuery is working, however when I select a package which you have to do the URL changes which throws up errors within the console when I view it... The URL when the package is selected changes to this...

wp-admin/post.php?post=0000&action=edit&package_id=2

These are the errors that get thrown up..

enter image description here

It almost appears as though with the extra tag on the end of the URL the JQuery is not being read at all?

2 Answers 2

2

There are this type of problem occure. In case-

1- jQuery function conflict to other jquery function. To remove this type of problem, define below script in wp-config.php file.

define('CONCATENATE_SCRIPTS', false);

2- jQuery liberaray file are not include in frontend.

3- Jquery same file defined more than one time. then this type of issue show in firebug.

1
  • You just saved my day. Thank you for this treasure config. Mar 22, 2020 at 18:36
1

When connecting your scripts indicate that the script should work when connected to jQuery:

  function my_custom_script() {
    wp_enqueue_script('my_custom_script', plugins_url('/js/script.js', __FILE__), array('jquery'), '1.0', true);
}

add_action('admin_enqueue_scripts', 'my_custom_script');

stated that the need: array('jquery')

Not the answer you're looking for? Browse other questions tagged or ask your own question.