1

I am really struggling to move Wordpress from an external host to my localhost (xampp). After two days trying to do this I am now at the stage where I can access the homepage and admin panel, but nothing else.

I have accessed permalinks and clicked save as shown below:

enter image description here

Here is the .htaccess file that is generated:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /Blog/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /Blog/index.php [L]
</IfModule>

# END WordPress

Here is the apache config:

Options All AllowOverride All

and:

LoadModule rewrite_module modules/mod_rewrite.so

For example, when I try to access: http://ianscomputer/Blog/about-2/; I see this in Fiddler:

enter image description here

What is the problem?

Update Here are some more settings:

enter image description here

enter image description here

  • Have you updated wp-config.php, wp-options table in database and changed both site url and website url in admin panel? – Jack Johansson Feb 12 '17 at 11:29
  • @Jack Johansson, I have added three more screenshots to my question in answer to your questions. – w0051977 Feb 12 '17 at 11:40
  • @Jack Johansson, I have also noticed that I cannot browse to: ianscomputer/blog - I can only browse to: localhost/blog. If I change the wp-options values to localhost/blog then I cannot browse to localhost/blog, but I can browse to ianscomputer/blog. – w0051977 Feb 12 '17 at 11:41
  • you forgot the ending / in your URLs. Try adding that and see if it helps after clearing the cache. – Jack Johansson Feb 12 '17 at 11:44
  • @ Jack Johansson, I will try that and report back. Hold on... – w0051977 Feb 12 '17 at 11:47
0

@w0051977 after re-reading this issue, I started thinking of something that could be the actual issue; your "domain name".

Please note: I always work on Windows, so I could be wrong in some or all areas. I'm trying to use my best guess work here.

During my test environments (local), I always have a top-level domain name, e.g. ianscomputer.internal. While I was learning WP, I had some difficulties because I was using only localhost. Honestly, I didn't take the time to learn why, so I just created a fake "full domain name" and moved on.

Based on the stated above, I did a quick Google search and came across this post: Faking a top-level domain name for local development with Apache which says:

Not every CMS (looking at you Wordpress!) has relative paths to their content.

So I would say:

  1. Follow the steps to create a fake top-level domain. (Super guess x3)
  2. Check Apache settings as suggested on this post: [How to trace Apache 301 Moved Permanently?]https://serverfault.com/questions/361165/how-to-trace-apache-301-moved-permanently.
  3. Get rid of the :80 in all settings. When using http:// before the domain, this is stated. (Personal opinion)
  4. While testing, change your permalink structure to Default. It will make your troubleshooting easier. (Personal opinion)

Test the above and let us know what works and does not work.

I hope this helps and good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.