I installed wordpress 4.7.2 from cPanel control panel using 'Softaculous Apps Installer'. The installer has setup the database automatically without any issues. I am able to login and could access other features except customize.

enter image description here

I did not change anything in the code. I logged in through wp-login and tried to customize by clicking the customize button. The page is blank. No error message was displayed. This is the first user interaction i did. I checked the error log in my server. There was nothing related to this path.

What is missing here?


After a day of the above question I created another folder wordpress in my server and copied the zip file to that folder. I extracted and ran sitename.com/wordpress . It asked for database creds and provided. Installation was successful. Loggin page appeared and i logged in. I clicked customized button and got the following error

Allowed memory size of 33554432 bytes exhausted (tried to allocate 1200 bytes) in wp-includes/media.php on line 2813

Mine is a shared hosting environment.

I increased the limit to 512MB. Now the error did not appear but the page is blank. Back to zero.

  • Have you tried updating your WordPress installation through the update section in admin panel? WordPress 4.2 is pretty old. Updating to a fresh copy might solve your problem. – Jack Johansson Feb 7 '17 at 2:03
  • I am sorry. Typos.. it is 4.7.2 – Jayapal Chandran Feb 7 '17 at 2:31
  • I have updated the version and the question to clear off the database puzzle – Jayapal Chandran Feb 7 '17 at 2:35
  • which theme are you using? – David Lee Feb 7 '17 at 2:43
  • The default one. I did not change anything other than the site title. – Jayapal Chandran Feb 7 '17 at 2:45

Can you create a "test admin" user and see if you can access the customize page then? Also, silly question... but have you tried different browsers, clearing out cookies, etc..?

I would also disable all plugins - even the pre-installed plug-ins that come with a fresh Wordpress install. If that doesn't work, try to activate another "default" theme and see if it works.


Not familiar with Softaculous, but when you first time running WordPress, point your URL to www.example.com/wp-admin/install.php to setup the site. Also, have you create a database for WordPress yet? White-screen-of-dead could be many reasons, but giving that this is a fresh installation, it is most likely due to database has not been setup properly yet. See this for more information. If this still not working, provide your directory structure on how the wordpress is installed and the wp-config.php setting related to 'DB_NAME' and 'DB_HOST' for further diagnostic.

  • 1
    he mentioned that he is able to log in to the admin panel, which means the database is set up properly and the installation is done. – Jack Johansson Feb 7 '17 at 2:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.