0

So I have a website which is made by using Wordpress platform. I'm completely unaware of SEO and when I search for my website on Google the description is something like this

A description for this result is not available because of this site's robots.txt

My Wordpress robots.txt file content is as follows

User-agent: *

Disallow: /wp-admin/
Allow: /wp-admin/admin-ajax.php
Sitemap: http://www.loadsofshoes.com/sitemap.xml
Sitemap: http://www.loadsofshoes.com/sitemap-images.xml
1

Content of robots.txt is right. Site should be indexed. Probably some time ago indexation was prohibited in WordPress settings.

What you can do, request re-indexing of your site in Google Search Console and in some time (one week maybe) you can see usual description of your pages in Google search results.

0

Are you sure you have uploaded your sitemap.xml? I have just checked the URL and the page cannot be found. If you are not familiar with sitemap.xml files, and/or want to 'start as you mean to go on' with SEO, you may find a Plugin such as the 'All in One SEO Pack' or 'Yoast' of interest.

Have you tried just placing:

User-agent: *
Disallow: /wp-admin/

in your robot.txt file?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.