I've faced one really annoying "bug" on my production website. I've recently migrated to a new hosting, things went fine, then this issue started showing up.

YES, I was googling for past 3 days in order to fix this issue, and not a single solution helped.


When I try to edit some post, or try to add a new - I get no Visual editor, only the button Add Media is shown up. I can not add text. Also, plain HTML editor doesn't work as well.

The whole thing looks like this:

enter image description here

What I've tried:

  • Disabled plugins
  • Switched theme Cleared cache & cookies
  • Switched browser
  • Repaired DB
  • Enabled Debugging - no errors
  • Checked logs - no issues with PHP
  • Reinstalled the whole Control Panel
  • Tried various solutions from WP forums -Nothing.

I believe it is somehow Control Panel related, because when I created a subdomain, ran the installation with the latest WP version - I faced the same issues.

Same version works with no prob's on my localhost.

  • WP version: 4.7.2
  • PHP 5.6

Any suggestion guys, I am really desperate..

EDIT: For some reason - seems it is fixed now. I disabled all plugins, and enabled one by one while refreshing post page, checking does something breaks. Not sure can this be considered as a fix, because I did the same couple of times. Thanks for help!

  • Questions: 1) What page builder are you using? 2) can you access WordPress error log & add that to your question?
    – Fayaz
    Feb 4, 2017 at 2:45
  • the only suggestion is the usual, turn off plugins, switch to default theme, and than turn things back on, untill you discover the source. Than ask for support from the plugin/theme author Feb 4, 2017 at 5:45
  • I ran into this as well. None of the answers helped. Also did all the usual: switch themes, disable all plugins, clear caches, etc. Nov 28, 2018 at 15:44

6 Answers 6


I had the same problem and it was solved by following an advice found on https://wordpress.org/support/topic/visual-editor-missing-15/

  1. Go to the file wp-config.php
  2. Find the following line:

define('DB_HOST', 'xxxxxxxxxxxx');

  1. Right below the above line add this:

define('CONCATENATE_SCRIPTS', false);


Maybe you should change memory limit, because sometimes this give a White Screen as well. Often a problem when using woocommerce or lots of plugins.

Can be change this way, add rule to config.php

define( 'WP_MEMORY_LIMIT', '256M' ); 

Log into your WordPress dashboard. On the left-hand side, go to Users > Your Profile. Uncheck the box beside "Disable the visual editor when writing". Click on "Save" at the bottom of the page.

If the check box was already disabled, check it and click on "Save" and the uncheck it and click on "Save".

This should solve the problem


First off, go to Users->Your Profile. And make sure that the box marked "Disable the visual editor when writing" at the top of the screen is not checked.

If that setting is correct, then your browser can help you identify JavaScript issues or conflicts. Do you have any Javascript errors in the console when looking at the editor page? This article can assist you in doing that diagnosis.


Please open your profile in your WordPress site dashboard and make sure that Disable the visual editor when writing checkbox is not checked.

  • Tried that @Darshan Saroya , but didn't helped.
    – fugitive
    Feb 4, 2017 at 18:18
  • Please deactivate your plugins one by one and check it. You can also switch theme to default to check. Feb 4, 2017 at 19:12

'Add Media' button is not working?

If you answer 'yes' take a look if jQuery is not loaded twice, if so, load one only or implement JQuery.noConflict().

  • How would one check if jQuery was loaded twice? Nov 28, 2018 at 3:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.