3

I have a strange issue. Trying to update core wp version from 4.7 to 4.7.2 but wp keeps saying I am already up to date. But when I run

wp core version

Then I see 4.7 and not 4.7.2

Any ideas on how to troubleshoot ?

2
  • Have you tried wp core version --extra? What do wp core check-update and wp core update say?
    – swissspidy
    Commented Feb 1, 2017 at 20:39
  • core check-update just says "You are up to date".
    – codegeek
    Commented Feb 4, 2017 at 18:07

1 Answer 1

1

What is inside your version.php file?

File: /wp-includes/version.php
1: <?php
2: /**
3:  * The WordPress version string
4:  *
5:  * @global string $wp_version
6:  */
7: $wp_version = '4.7.1';

You can play with that number and test.


You can try to install the latest version of WP Cli and test. You may update to WP-CLI version: 1.1.0 if the older version had problems. (I found out you used the 1.0 version of WP-CLI before).

7
  • version.php shows '4.7' which is what wp-cli also returns. But then I cannot update to 4.7.1 for some reason. Wondering if my wp-cli is broken.
    – codegeek
    Commented Feb 4, 2017 at 18:09
  • Good thinking. Try with the wp-cli latest version possible. Recently several topics were due to wp-cli not performing well and reinstalling it from scratch it worked.
    – prosti
    Commented Feb 4, 2017 at 18:17
  • 1
    yea i just tested with latest version and it worked now. strange.
    – codegeek
    Commented Feb 4, 2017 at 18:18
  • @codegeek, would be good if you check the green ✔, just for others who may have the same problem. I really haven't got the idea at first this would be the problem, but I would for sure mention you to reinstall the wp-cli in the later course.
    – prosti
    Commented Feb 4, 2017 at 21:15
  • happy to mark as answer but the issue was that version 1.0 of wp-cli did not work..version 1.1 worked. can you update your answer to just say that ?
    – codegeek
    Commented Feb 5, 2017 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.