I am receiving the error message:

"HTTP error."

in Wordpress when trying to upload a 300 MB FLV file to the media library.

Environment

  • Wordpress 4.7.2

  • PHP 5.6.27

  • IIS 7

  • Windows Server 2008 R2

up vote 1 down vote accepted

The most common answer to this question is:

Check your php.ini settings and make sure the following variables are larger than the size of the file you're trying to upload (in this example we'll set the values to 500 MB):

upload_max_filesize = 500M
post_max_size = 500M

However, in my scenario this was not the solution. Instead we needed to do the following:

  1. Launch Internet Information Services (IIS) Manager
  2. Select the IIS server object in the Connections list on the left.
  3. Double-click: Request Filtering
  4. Edit Feature Settings...
  5. Verify "Maximum allowed content length" is set to a value larger than your file size. The maximum value for this setting is 4294967295.

You may have site specific settings that override the global settings. If this is the case, step 2 is:

  1. Select your site object in the Connections list on the left.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.