0

Using Apache 2.2, Wordpress 4.4, Better WP Security. I have logged in, can browse all pages on front-end, but when I try to access any link that is on wp-admin I get 404 page. I don't have any ideas left for this situation.

I've tried with no luck to:

  • disable plugins, as just BWS, and all plugins
  • delete/reset .htaccess,
  • set all folders and files to 777
  • looked into table itsec_lockout but there's no my IP address
  • searched sql table itsec_log and what I get for my IP in log_data is a:1:{s:12:"query_string";s:0:"";}, what is that?

What is left to try?

  • and you can access any other page in the front-end ? – prosti Jan 26 '17 at 10:53
  • Yes I can, and logged in and logged out. With no difference. – Nemanja Đatkov Jan 26 '17 at 10:56
  • and why do you use 4.4, 4.7 is much too expensive or? – prosti Jan 26 '17 at 10:58
  • Because it is possible that website will brake due to plugins and theme setup. I haven't work on website development, so don't know what is modified. – Nemanja Đatkov Jan 26 '17 at 11:01
  • OK fair enough, have you enabled the error log? – prosti Jan 26 '17 at 11:02
0

You need to enable the error logging in WordPress from the wp-config.php

define( 'WP_DEBUG_LOG', true );

After that, you will probably get some feedback inside:

wp-content/debug.log

Above that, you can try to get the exact feedback you get from 404 page. Check the console in the inspector, and the response from te webserver.

curl -I http://yourwebsite.com/wp-login.php

Looks like inside your theme you have some redirecting problem. Try to remove the plugins, the theme and to set the 2017-teen new theme to check if this is true.

I hope you will isolate the issue soon.


What I suggest, you create the test environment somewhere and upgrade the website to the latest version of WordPress.


The other things you may investigate: (1) you may have the altered WordPress core somehow, and (2) you may have some .htaccess files other than the WordPress root folder.

| improve this answer | |
0

Mistakes are stupid as always. There was some unexpected .htaccess file in wp-admin folder witch says Deny All Everything and for Good. Anyway thank you guys for your help!

| improve this answer | |
  • I predicted this as a possible cause. Glad you were able to fix this out @Nemanja Đatkov. Not an easy fix. – prosti Jan 26 '17 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.