0

I can’t do a subdomain network activation, despite my WP install being in my Apache webroot: /var/www/html.

My WP install only gives me the option for a subdirectory-based network.

“Because your install is in a directory, the sites in your WordPress network must use sub-directories.”

I access my site at http://192.168.1.20/ (it’s an private network for now), and WordPress’ index.php is in the webroot. There is no subdirectory for WordPress. I can create/manage/access the base site, but can’t do a subdomain network creation.

I’ve blown up the DB and recreated the install, and it behaves the same way.

Help please? What can I check? Any hints to resolve?

Thanks!

1

You need to have domain name resolution in order for subdomain Multisite to work. If you don't have a Domain Name Server, you can modify your computer (not your server) hosts file.

Then, make sure your primary WordPress installation is set to a domain name, such as server.example, and not an IP address.

  • That solved it. Going from accessing and creating the site via its IP to its hostname unlocked the subdomain option. Thanks for your help! – bhansley Jan 24 '17 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.