0

Desperate for help!

I MANUALLY transferred a WPMU site to a new server, root folder, and now have a constant “Upload folder is not writable. Export and file upload features will not be functional.” which in fact turns out to be true. I’m unable to export/import my WooCommerce CSV files.

I’ve set attributes to /wp-content/uploads to 777, to no avail. I’ve searched google and WP forums, to no avail – I desperately need some direction on how to fix this problem. If anyone could please step in and offer me some help I’d be so very grateful.

  • 1
    755 should be plenty, for folders. Did you recurse the chmod through all the subfolders within the /uploads/ directory? – C C Jan 23 '17 at 20:23
  • 1
    Have you tried your host provider about this issue? Most of the times they can resolve these type of problems quickly. – Jack Johansson Jan 23 '17 at 23:43
0

thanks to both of you who answered. The problem turned out to be that there are more than one rows in wp_options which refer to the uploads folder: upload_path, upload_url_path and fileupload_url - I had only found one of these when I searched "upload_url" and missed the first one, which was of course pointing to the old server.

By searching "upload path" i found all three, made the correction and solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.