1

I am suddenly getting a Sorry, this file type is not permitted for security reasons while trying to upload some file extensions which used to work.

Specifically, jpg doc txt ods work, rtf docx xls xlsx are not allowed.

Sorry, this file type is not permitted for security reasons

  • The file types are listed in Network settings > Upload file types

    Network settings > Upload file types

  • I also checked in the database upload_filetypes.

    wp_sitemeta > upload_filetypes

  • Also checked with get_allowed_mime_types()

    enter image description here

  • Tried adding with upload_mimes filter - and a couple of plugins, checked .htaccess to no avail. I also tried with all the plugins off.

  • Also, on the same shared hosting account there are other instances of WP where the uploading is not limited.

What could I do next?

3
  • nice quest @pax
    – prosti
    Jan 19 '17 at 11:54
  • Were you looged in as admin?
    – prosti
    Jan 19 '17 at 11:56
  • yes, logged as admin
    – pax
    Jan 19 '17 at 12:27
1

Known issue that was introduced in 4.7.1:

https://core.trac.wordpress.org/ticket/39550

There is a plugin to workaround it for those having this problem. A fix will likely be in the next release.

https://wordpress.org/plugins/disable-real-mime-check/

2
  • Using WP v4.8 and still have this problem with .xls file. Had to install this plugin to workaround.
    – Sisir
    Jul 11 '17 at 16:46
  • The issue is not "fixed", however it is "reduced". Even without that plugin, it is quite likely that if you opened your "XLS" file in Excel and then merely resaved it to another file, then you would find that that file would upload properly, no need for the plugin.
    – Otto
    Jul 11 '17 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.