0

Somehow, the default jQuery UI Datepicker (loaded by domain/wp-includes/script-loader.php on line 214 in version 4.7 is giving javascript errors in the console. This is the line that loads in the file:

$scripts->add( 'jquery-ui-datepicker', "/wp-includes/js/jquery/ui/datepicker$dev_suffix.js", array('jquery-ui-core'), '1.11.4', 1 );

And here is the error:

edit.php:81 GET http://jquery-ui.googlecode.com/svn/tags/latest/ui/i18n/jquery.ui.datepicker-nl.js?ver=4.7 

It returns with an 404. How do I fix this error?

I have searched within the wp-admin and wp-includes files, but I just can't figure out why this error is present.


IMPORTANT: I don't want to change any wp-admin code. Preferably, I want to use hooks via my custom plugin (or the theme's functions.php file)

0

The script itself is no longer on the google hosted link. You should try updating to Wordpress v4.7.1 or reporting the bug if it still persists after that

404 error

3
  • Is there no workaround? Because that's what I'm looking for Jan 13 '17 at 10:15
  • You could always enqueue your own local version of the script.
    – Tunji
    Jan 13 '17 at 10:17
  • Tried that already. Removing the 'jquery-ui-datepicker' line solved the issue, but dequeue'ing or deregistering the scripts did not solve the issue, even when I changed the priority Jan 13 '17 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.