I'm busy working on a website for myself, and within this (Wordpress) website I want to create a new (multisite) site. First I wanted to do everything according to several tutorials on the internet, but then it turned out to be already done by the theme I bought.

When I go to "Network Admin > Sites > Add New" there is obviously an option to add a new site. The only thing is is that it isn't a subdomain, it is just a new page/site after the slash (www.mysite.com/...). So:

The option now

When actually I just want newsubdomain.mysite.com.

I hope someone can help me with this! I can't get it to work, unfortunately.


1 Answer 1


This is the problem with Multisite setup. Check your wp-config.php file. Right under define('MULTISITE', true); you should have this:

define('SUBDOMAIN_INSTALL', true);

If this is set to true you will be able to add new sites as subdomains. After you do this re-check in wp-admin, what extra lines you need to add to .htaccess and wp-config and you are ready to go.

Once you create a new subdomain website check if it works, if you get an error message don't worry, you probably just need to add A record for your domain that ponts to your subdomain.

  • Thank you! It worked. :) I added a subdomain, but I'm getting an error now; When I go to mynewsubdomain.mywebsite.com I'm getting only a line of text saying; "Apache is functioning normally". And when I'm going to mynewsubdomain.mywebsite.com/wp-admin I'm getting a full (404) Not Found error. :(
    – richolio
    Jan 12, 2017 at 10:56
  • Ok let's try and fix this one :-), go to Network Admin / Network setup and check if you applied those exact changes to .htaccess and wp-config.php. I think there are some minor changes when you switch to subdomain option. After that check your domain DNS settings in order to make subdomain multisite work I neede to add a wildcard A record pointing to my server IP address. Note: if you change DNS records it will take some time to see if it fixes your problem, depending on TTL. Jan 12, 2017 at 11:02
  • I applied the changes to the .htaccess and wp-config.php! I'm in the Domain DNS settings now; do I need to call it mynewsubdomain.mywebsite.com and then point it? Edit: no, that didn't work (my domain and hosting on are different parties). How do I add a new record correctly? I'm kinda new to this. I can send a screenshot if you want
    – richolio
    Jan 12, 2017 at 11:11
  • Actually no. Try to add A record with name * that points to your server IP address. That way it is a wildcard that will detect all your subdomains. (If you go with your approach, Name: subdomain, you need to do this for every new site on the network). Jan 12, 2017 at 11:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.